Game Sheet: JMaPacman
(from the original archive of "The Linux Game Tome")

Description:

The old Arcade Pacman Game in a new Design for multiplayer Fun.

Play with your friends in many different Levels and try to eat as much pills as possible ;) You can eat Ghosts Fruits and Superpills to reach higher scores

Supported by Arianne Framework and Java
Author: Martin SpülerCompany:
Version: 0.3Category: Arcade
License: freeCost:
Votes: 2      Vote->      Rank: 4.5 / 5        N.A.
Source? Yes     Sound? NoXWindow (X11)? Yes     Console? No
3D Accelleration? No     Multiplayer? YesPlay Online? Yes     Submitter: TheeParanoid
Other requirements:
Java 5.0
Homepage:
http://arianne.sourceforge.net/?arianne_url=games/game_jmapacman
Server HomePage:
http://jmapacman.mpc-donkey.de
Download Sources:
http://prdownloads.sourceforge.net/arianne/jmapacman-0.3-src.tar.gz?download
Download:
http://prdownloads.sourceforge.net/arianne/jmapacman-0.3.zip?download
Last updated: 2005-07-11 00:34:58

Comments

Date: 2005-06-23 02:42:25     User: GriZZ     Subject: JMaPacman
Hmmmm... Great idea, but I have too many lags :(
     
Date: 2005-06-23 06:25:05     User: TheeParanoid     Subject: Re: JMaPacman
mmmh, what connection do you have .. and do you running any kind of p2p (aMule, Bittorrent) or any other bandwidth-consuming application ??
     
Date: 2005-06-23 07:58:57     User: GriZZ     Subject: Re: JMaPacman
LAN. On www.numion.com I have 64kbps [the world] and about 160kbps [Poland]. I have installed Steam and PeerGuardian.
     
Date: 2005-06-28 07:02:00     User: anonymous     Subject: problem
java -jar /home/nethanel/paq/jmapacman-0.02.jar Exception in thread "main" java.lang.UnsupportedClassVersionError: games/mapacman/client/MaPacman (Unsupported major.minor version 49.0) at java.lang.ClassLoader.defineClass0(Native Method) at java.lang.ClassLoader.defineClass(ClassLoader.java:539) at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) at java.net.URLClassLoader.defineClass(URLClassLoader.java:251) at java.net.URLClassLoader.access$100(URLClassLoader.java:55) at java.net.URLClassLoader$1.run(URLClassLoader.java:194) at java.security.AccessController.doPrivileged(Native Method) at java.net.URLClassLoader.findClass(URLClassLoader.java:187) at java.lang.ClassLoader.loadClass(ClassLoader.java:289) at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274) at java.lang.ClassLoader.loadClass(ClassLoader.java:235) at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)
     
Date: 2005-06-28 07:49:32     User: arianne_rpg     Subject: Re: problem
You need Java 1.5 to run JMaPacman.
We, on Stendhal, are working to be able to compile it for Java 1.4 and the results will be used too on JMaPacman.
     
Date: 2005-07-11 02:48:35     User: arianne_rpg     Subject: Nice work
Hehe, Much better than mapacman.
I have to say that I ran it for testing and I kept playing until i reached the 1st position.

Nice way of adding several levels in a pacman game.

I find it a bit laggy though, perhaps it is my connection.
     

Date: 2005-07-11 07:39:54     User: pawn     Subject: black screen
ive installed java-jre-bin 1.5 and java-sdk 1.5. When i launch the game, my login is accepted then nothing happen, i see this black screen
     
Date: 2005-07-12 07:14:48     User: TheeParanoid     Subject: Re: black screen
somehow the server crashed ... but I restarted the server and everything should work perfect again ;)
     
Date: 2005-07-12 07:31:46     User: pawn     Subject: Re: black screen
im sad :(... it still doesnt work on my box.... same issue as described above.
     
Date: 2005-07-12 08:46:23     User: TheeParanoid     Subject: Re: black screen
strange ... should work ... what version are you using ?? 0.3 ? Try to run from console .. any execptions ?
     
Date: 2005-07-12 09:17:41     User: pawn     Subject: Re: black screen
Here's what i get on the console:

[email protected] ~/dl/games/pacman $ java -jar jmapacman-0.3.jar
Trying to login to jmapacman.mpc-donkey.de:9923
logged in as cghislai
FPS:10
FPS:10
FPS:15
FPS:15

im using gentoo with (unmasked) sun-jdk 1.5.0.04 and sun-jre-bin 1.5.0.04
     
Date: 2005-07-12 11:53:18     User: TheeParanoid     Subject: Re: black screen
sorry .. don't have any idea. Using same system (gentoo,too ;) ) and same java version ....and it works for me
     
Date: 2005-07-12 11:56:42     User: TheeParanoid     Subject: Re: black screen
mmmh, not sure if it's exactly the same java-version ... "java -version" shows this : java version "1.5.0-gentoo" Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0-gentoo-1113234042)Java HotSpot(TM) Client VM (build 1.5.0-gentoo-1113234042, mixed mode)
     
Date: 2005-07-13 03:22:47     User: pawn     Subject: Re: black screen
youre right, this is not the same version... But even after re-syncing the tree, it seems that the 1.5.0.04 is the only 1.5 version availible, and theres no gentoo patch :( so maybe you can send me your ebuilds so i can try with your version... Thanks
     
Date: 2005-07-13 03:41:04     User: pawn     Subject: Re: black screen
youre right, this is not the same version... But even after re-syncing the tree, it seems that the 1.5.0.04 is the only 1.5 version availible in portage, and theres no gentoo patch :( so maybe you can send me your ebuilds so i can try with your version... Thanks
     
Date: 2005-07-13 03:41:23     User: pawn     Subject: Re: black screen
youre right, this is not the same version... But even after re-syncing the tree, it seems that the 1.5.0.04 is the only 1.5 version availible in portage, and theres no gentoo patch :( so maybe you can send me your ebuilds so i can try with your version... Thanks
     
Date: 2005-07-13 03:41:24     User: pawn     Subject: Re: black screen
youre right, this is not the same version... But even after re-syncing the tree, it seems that the 1.5.0.04 is the only 1.5 version availible in portage, and theres no gentoo patch :( so maybe you can send me your ebuilds so i can try with your version... Thanks
     
Date: 2005-07-13 03:49:42     User: pawn     Subject: Re: black screen
wow, excuse me.... there were connection problems and ive tried to update the page several times.... sorry